[Mimedefang] 2.2 Mutiplexor not plexing

Nathan Schimke nathan at cray.com
Wed Jan 16 17:53:55 EST 2002


Michael Sofka wrote:
>I've been running mimedefang 2.1 for 3 weeks.  Today I tried updating to 2.2,
>but had to back out the update.  The mimedefang-multiplexor was not multiplexi
>ng
>correctly, or fast enough.
>
>When trying this on a test machine, what happens is that, as expected,
>when a lot of email is sent more slave processes are started.  But, not enough
>start and not fast enough, and sendmail starts rejecting mail with "try again 
>later."
>
>Running with -d the logs show more slaves being started, but there is no error
>to indicate it is out of slaves, or anything was wrong with the slaves that ar
>e
>started.  In fact, once they are running resending the flood of email works fi
>ne,
>until the extra slaves are killed.

I've had a problem which sounds similar to this, with 2.2 beta 3
running on Solaris 8 using the multiplexor.  Whenever there's a
reasonable amount of traffic flowing, a few connections would get the
"please try again later" right away.

It seems that when two threads try to create temporary directories at
the same time, mkdir() fails in at least one of the threads with error
EBADF.  Mimedefang isn't expecting that so it exits back to sendmail
with a temporary-failure result.  I just tried adding a check so
mimedefang does a re-try after the EBADF, and that seems to have made
the problem go away.


*** mimedefang.c.orig   Fri Dec 21 09:45:33 2001
--- mimedefang.c        Wed Jan 16 16:39:52 2002
***************
*** 418,424 ****
            success = 1;
            break;
        }
!       if (errno != EEXIST) {
            break;
        }
      }
--- 418,424 ----
            success = 1;
            break;
        }
!       if ( (errno != EEXIST) && (errno != EBADF) ) {
            break;
        }
      }



More information about the MIMEDefang mailing list