[Mimedefang] negotiate error: version 13 not 2?

Pekka Saari pekka.saari at sll.fi
Wed Mar 6 00:39:45 EST 2002


>On Tue, 5 Mar 2002, Nicholas Brealey wrote:
>> I ran into a problem where I had old versions of mfapi.h and
>> mfdef.h in /usr/include/libmilter and new versions in /usr/include
>> and mimedefang picked up the old include files.

In Mimedefang README it is adviced to:
   cp -R include/* /usr/local/include/sendmail
which ends up to:
   /usr/local/include/sendmail/libmilter/mfapi.h

However, because I have redhat, I stipped the "local":
   cp -R include/* /usr/include/sendmail
which ends up to:
   /usr/include/sendmail/libmilter/mfapi.h

However, configuring mimedefang complained that
libmilter/mfapi.h is not found.

So I added
   cp -a /usr/include/sendmail/libmilter /usr/include/libmilter
After that I could configure and install mimedefang.

Sendmail installs also:
    /usr/include/mfapi.h

So now I have these files in THREE places:
   /usr/include/sendmail/libmilter/mfapi.h
   /usr/include/libmilter/mfapi.h
   /usr/include/mfapi.h

   /usr/include/sendmail/libmilter/mfdef.h
   /usr/include/libmilter/mfdef.h
   /usr/include/mfdef.h

Pekka





More information about the MIMEDefang mailing list