[Mimedefang] MD and uvscan permissions

Ole Holm Nielsen Ole.H.Nielsen at fysik.dtu.dk
Wed Sep 10 15:57:01 EDT 2003


I used to see sendmail rejections, too, like this in the maillog
of a Redhat 9 server:
    Milter: data, reject=451 4.3.0 Problem running virus-scanner

If you try to run uvscan from the command-line, it hangs forever.
This is a known problem with uvscan on Redhat 9 picking up the wrong
shared libraries, see
    http://www.sng.ecs.soton.ac.uk/mailscanner/serve/cache/153.html

I now use this wrapper as /usr/local/bin/uvscan:

#!/bin/sh
export LD_PRELOAD=/lib/libc.so.6
exec /usr/local/uvscan/uvscan $*

Stefano McGhee wrote:
> 	I'm trying to setup uvscan on a newly built machine (RH8) running
> MD, and it seems that I am getting Permission Denied when (presumably)
> defang tries to run it when a message comes in.  I am seeing this in the
> maillog.  
> 	I experienced uvscan hanging on RH9 and remembered the whole
> threading model thing, so I just went back to RH8 for the time being.  
> 	I've tried logging in as myself, su to root and su to defang and
> running uvscan.  It works fine.  Works fine when I run it as root and
> myself as well.  I even checked all the .dat files to ensure that they are
> chmod 644.  Anything else I might check?

Ole Holm Nielsen
Department of Physics
Technical University of Denmark





More information about the MIMEDefang mailing list