AW: [Mimedefang] mimedefang.sock

A.Jones at mvv.de A.Jones at mvv.de
Thu Nov 4 01:46:03 EST 2004


It might be good to know what kind of hardware You are running on, and what
the load is like when You start MIMEDefang. We use an UltraSPARC III (~1GHz)
box, and i have had to add logic to my start script to wait 5 or 10 seconds
after starting MIMEDefang, because i had the same problem -- it just takes a
little while. I realize 5 to 10 seconds is not the same as 3 minutes, but
that's why i ask about the hardware and system load.


-----Ursprüngliche Nachricht-----
Von: David F. Skoll [mailto:dfs at roaringpenguin.com] 
Gesendet: Mittwoch, 3. November 2004 19:57
An: mimedefang at lists.roaringpenguin.com
Betreff: Re: [Mimedefang] mimedefang.sock


On Wed, 3 Nov 2004, Chris Masters wrote:

> Maybe it's worth calling smfi_opensocket to explicitly
> create the socket prior to calling smfi_main as a
> double check.

Unfortunately, smfi_opensocket is a _FFR in Sendmail 8.12,
so the configure script would have to detect whether or
not it's available.

> Anyway, this must be an issue with the way libmilter
> closes and then reopens the socket. 'mimdefang' (the
> milter) is running at the time (I guess it's also
> waiting for the socket; return from smfi_main).

libmilter shouldn't be closing and reopening the socket,
should it?  It only gets closed at the end when milter is
shutting down.

I've never seen the behavior you describe.  Can you strace
the milter to see what's happening?

--
David.
_______________________________________________
Visit http://www.mimedefang.org and http://www.canit.ca
MIMEDefang mailing list
MIMEDefang at lists.roaringpenguin.com
http://lists.roaringpenguin.com/mailman/listinfo/mimedefang



More information about the MIMEDefang mailing list