[Mimedefang] MIMEDefang can't get directory for auto-whitelist file lock

Kees Theunissen theuniss at rijnh.nl
Thu Aug 3 14:47:45 EDT 2006


On Thu, 3 Aug 2006, Karl Boyken wrote:

> Whenever we reboot our mail server, MIMEDefang always starts tossing these
> errors when it comes back up:
>
> Aug  3 10:44:21 serv07 mimedefang-multiplexor[2864]: Slave 3 stderr:
> auto-whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot
> create lockfile //.spamassassin/auto-whitelist.mutex: No such file or directory
>
> But if we stop and restart MIMEDefang, the problem goes away; MIMEDefang can
> then grab the home directory of the user it runs as.  Any ideas as to why this
> might be happening?  We're running MIMEDefang 2.55 and SpamAssassin 3.1.3 on
> RedHat Linux Advanced Server 4.

First a quote from a previous message from my on this list
  Date: Thu, 8 Jun 2006 04:27:10 +0200 (CEST)
  From: Kees Theunissen <theuniss at rijnh.nl>
  Subject: Re: [Mimedefang] Seeing whitelisting errors

<start quote>

This is exactly the problem I had.
I'm running Fedora Core 4 with MIMEDefang 2.56 and SpamAssassin 3.1.3
installed from CPAN. I upgraded today from SpamAssassin 3.1.1 which
had the same error. The upgrade didn't solve the problem.

I'm using the redhat startup scripts from the MIMEDefang distribution
and I'm getting these error logs for every message that is scanned _only_
after a reboot. The errors disappear after a manual restart of MIMEDefang
and sendmail ( service sendmail stop; service mimedefang restart;
service sendmail start ).
Note the leading //.spamassassin/... (starting with two slashes) in
the paths that are logged.
And no, '/' is not the home dir of my defang user.

This looks like SpamAssassin having trouble to determine the home dir
of the MIMEDefang (and SpamAssassin) user when the program is launched
at boot time from the FC4 startup scripts.
Adding the line "export HOME=/path/to/defang/homedir/" (without quotes)
to the config script /etc/sysconfig/mimedefang solved this problem

<end quote>

I solved / worked around the problem by defining the $HOME environment
variable in the startup files.
It is clear that the bug is triggered by differences between the
boot-time and run-time environments on a RedHat/Fedora system.
But should this be considdered a bug in RedHat/Fedora, in Mimedefang
or in SpamAssassin? I didn't find time to investigate this further
and to report the bug at the right place.


Regards,

Kees.

--
Kees Theunissen
F.O.M.-Institute for PlasmaPhysics "Rijnhuizen", Nieuwegein, Netherlands
E-mail: theuniss at rijnh.nl,  Tel: (+31|0)306096724,  Fax: (+31|0)306031204



More information about the MIMEDefang mailing list