[Mimedefang] Failures after upgrade to Perl 5.8.5

Info Webintegrations info at webintegrations.co.uk
Tue Nov 20 11:06:45 EST 2007


Jan-Pieter Cornet wrote:
> On Mon, Nov 19, 2007 at 10:16:17AM +0000, bob.gray wrote:
>   
>> I am a new user of mimedefang, but have been delighted with it over the 
>> last two months. However, this weekend our Centos 4 servers received a 
>> Perl upgrade to 5.8.5, which caused mimedefang to stop working, indeed 
>> to stop sendmail operating at all.
>>     
>
> So why exactly did you "upgrade" to a perl version from 2004? If that
> is the latest that your OS supports, then it is seriously lagging in
> releases.
>
>   
Jan-Pieter

This was the release that stopped mimedefang working for us. Mimedefang 
then stopped sendmail working.

"Nov 5th 2007
Today Red Hat has released a security upgrade for Perl:
https://rhn.redhat.com/errata/RHSA-2007-0966.html

Updated Perl packages that fix a security issue are now available for Red

Hat Enterprise Linux 3, 4, and 5.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

A flaw was found in Perl's regular expression engine. Specially crafted
input to a regular expression can cause Perl to improperly allocate memory,
possibly resulting in arbitrary code running with the permissions of the
user running Perl. (CVE-2007-5116)

Users of Perl are advised to upgrade to these updated packages, which
contain a backported patch to resolve this issue. "


-- 
Web Integrations
2 Market Square
Stonehaven AB39 2BT
www.webintegrations.co.uk
01569 763300



More information about the MIMEDefang mailing list