[Mimedefang] Failures after upgrade to Perl 5.8.5

Adam Lanier adam at krusty.madoff.com
Tue Nov 20 11:36:12 EST 2007


On Tue, 2007-11-20 at 16:11 +0000, Paul Murphy wrote:
> 
> > Thanks for you comments.
> > Perl 5.8.5-37 was released for RHEL 4.4 on November 5 2007 as far as
> I 
> > am aware.
> 
> Yes, it is a new patch to a very old base version, with very old
> libraries as part of it.  If you have to run these old versions to avoid
> being outside of the supported version for RedHat, then all of the
> dependencies are your problem, as RH aren't interested in the latest and
> greatest, merely in the most stable version which doesn't break anything
> since their first release of 4.0 several years ago (Feb 2005).
> 
> Your alternatives are to get a newer Perl, or to install the dependent
> libraries yourself.
> 
> Paul.
> 
> -------------------------------------------------------
> Paul Murphy
> Head of I.T.
> Argenta Discovery
> Tel. 01279 645 554
> Fax. 01279 645 646
> 
> 

I'm running RHEL 4.6 here with Sendmail 8.13.8 and mimedefang 2.63. No
problems here.

[adam at selma ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux ES release 4 (Nahant Update 6)
[adam at selma ~]$ perl -V
Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
...snip blah blah blah...
[adam at selma ~]$ sudo up2date -u

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching rpm headers...

Name                                    Version        Rel     
----------------------------------------------------------

All packages are currently up to date




More information about the MIMEDefang mailing list